Welcome aboard Visitor...

Daily Screenshot

Server Costs Target


Target met!

Latest Topics

- Holly Cow Its alive!! »
- How did Darkspace loose it's customers? »
- "GCQL MFC stopped working" when launching the app »
- Re: Ich verabschiede mich »
- Things Dark Space needs to Address »
- other games ? »
- Random Lobby Quotes »
- Credits »
- When to play? »
- A few years ago »

Development Blog

- State of DarkSpace Development »
- Potential planetary interdictor changes! »
- The Silent Cartographer »
- Cloaking update... »
- Tools for tips »
- Fleet levels and more! »
- Game Mechanics Question and Answer Thread »
- Under Construction »
- Ship Tiers and You »
- Give Credits feature now live! »

Combat Kills

Combat kills in last 24 hours:
Kills chart
Killboard

Upcoming Events

- Towel Day
05/25/18 +216.9 Days
- International Talk like a Pirate Day!
09/19/18 +333.9 Days

Search

 

Anniversaries

No anniversaries today.

Facebook & Twitter

Why not follow us on Twitter or Facebook for more information and fan updates?

[FAQ
Forum Index » » Client Installation Issues (Hardware/Drivers) » » "GCQL MFC stopped working" when launching the app
 Author "GCQL MFC stopped working" when launching the app
AriesMu
2nd Rear Admiral

Joined: December 02, 2009
Posts: 38
From: Italy
Posted: 2017-08-02 15:45   
Hello everyone!

It's been a very long time! Now I have Win 10.

I was missing DarkSpace, so I downloaded it (actually the main client mirror doesn't work, so I had to use another mirror, but still the last version, 146 MB).

Installed, okay.

Launch: okay.

Login: okay.

Download updates: okay.

As soon as it tries to go further, I always get the same little window with this error:

GCQL MFC stopped working

And a load bar saying Windows is trying to find a solution, but uselessly.


I tried any compatibility mode, Win 8, Win 7, back to Win 98/Me, nothing.

I played with permissions, allowing full control to everyone, nothing.

It is installed in C:\\GameCQ
(not in Program Files).

I don't know what to do anymore. Any clue?

Thanks so much!
_________________


Doran
Chief Marshal
Galactic Navy


Joined: March 29, 2003
Posts: 4009
From: The Gideon Unit
Posted: 2017-08-02 22:19   
Quote:
On 2017-08-02 15:45, AriesMu wrote:
Windows is trying to find a solution, but uselessly.




being a win10 user myself, i know darkspace DOES run sufficently well, without the need for any special finagling.
most likely theres something interferring with darkspace's executables, but that could literally be anything. could be security software, could be the GPU driver
probably want to start by doing a minimum boot with as much non-windows/microsoft services and processes turned off, and start working upwards from there

_________________



  ICQ status
AriesMu
2nd Rear Admiral

Joined: December 02, 2009
Posts: 38
From: Italy
Posted: 2017-08-03 18:49   
Thank you so much Doran, I appreciate your suggestion.

How would you recommend to proceed to turn off these services? And which ones?

Thanks.
_________________


Pantheon
Marshal
Palestar


Joined: May 29, 2001
Posts: 1702
Posted: 2017-08-04 06:55   
Right click the GCQL icon and select "run as administrator", see if that works.
_________________


AriesMu
2nd Rear Admiral

Joined: December 02, 2009
Posts: 38
From: Italy
Posted: 2017-08-04 14:51   
Thank you Pantheon.

Yes, that was one of the first things I tried, unfortunately it doesn't work.

I also installed the dedicated AMD driver to make sure the application is set to use the dedicated Radeon GPU instead of the integrated Intel chip. Nothing works.

I don't know what else to try.

Thanks.
_________________


SnipeDragon
Marshal

Joined: January 03, 2005
Posts: 34
From: Texas, USA
Posted: 2017-08-06 10:43   
Do you have any virus/malware protection enabled?
_________________
Website Developer | Player Profile: AbueloHD

  Email SnipeDragon
AriesMu
2nd Rear Admiral

Joined: December 02, 2009
Posts: 38
From: Italy
Posted: 2017-08-06 12:09   
Quote:
On 2017-08-06 10:43, SnipeDragon wrote:
Do you have any virus/malware protection enabled?




Interesting!
Yes I do. But after reading your question I tried both deactivating the protection, and closing the software entirely (It's kaspersky antivirus).
It did not work

I also added GCQL.exe to the list of permitted applications in both the columns with the checkmark in Windows firewall. Nothing. Even with Kaspersky closed.

And, with all these stuff disabled, same error message both in native Win 10 mode, and Win 7 emulated mode.
_________________


Riley!
Chief Marshal

Joined: May 29, 2002
Posts: 256
Posted: 2017-08-06 22:25   
Do you have this installed? https://www.microsoft.com/en-us/download/details.aspx?id=3387
If not, install it and try re-running the application.

If it continues to crash, uninstall and delete the GameCQ folder, redownload the install file from a different mirror and try again.
[ This Message was edited by: Riley! on 2017-08-06 23:07 ]
_________________


Eledore Massis [R33]
Fleet Admiral
Templar Knights


Chatting in 'DarkSpace English'

Joined: May 26, 2002
Posts: 2677
From: tsohlacoLocalhost
Posted: 2017-08-28 17:39   
My 2 cent story of the fight Against "GCQL MFC Stopped working"

I a effort of upgrading my old Chat PC to windows 10, i bloody ran into multiple problems with GCQL.
It was to be expected from upgrading from Windows XP to win10 in one go.
But by darn i'v tried it on every one that laid between those two versions and they worked.
Until i'v tried it on actual Hardware, then it worked on windows 10 as well.
Yah i ran my Chat PC in a virtual machine.
And by darn i was annoyed that it just would not run on windows 10, i didn't wanted win8.1 or 7.
In a final effort to try it one more time. I installed win10 as a Hyper-v 'Generation 1' VM.
It Bloody worked! No reason why, and i actually don't give a reason why.
All instances i tried it on (except for XP) where 64bit, with 8gb of memory to be sure it ran in 64bit. (But Currently chugging with 2gb).

So yah, there are a few things that Generation 1 and 2 differ on but the main one is UEFI.
TBH i never have messed around with UEFI on my machines so i haven't been able to test if that is true or not. Or if it does lay with something else
But something between Windows 8.1 and 10 changed.
And it makes GCQL not happy.
_________________


DiepLuc
Chief Marshal

Joined: March 23, 2010
Posts: 1186
Posted: 2017-09-08 08:01   
There is another bug:
Engineer does not harvest resource when mining beam turns on. In that case, turns the mining beam off let the resources suddenly collecting in ship!
_________________


Powered by phpBB® Forum Software © phpBB Group
Page created in 0.034919 seconds.


Copyright © 2000 - 2017 Palestar Inc. All rights reserved worldwide.
Terms of use - DarkSpace is a Registered Trademark of PALESTAR